On Fri, Sep 13, 2013 at 06:09:48PM +0100, Liam Girdwood wrote:
Some codec drivers when running in slave mode require that FS is explicitly set by the machine driver as it may not be exactly BCLK/rate.
Extend the DAI API by adding :-
int snd_soc_dai_set_fs(struct snd_soc_dai *dai, unsigned int fs);
I'm struggling to think of a better name for this right now but the _fs name is making me think of the MCLK/SYSCLK rate rather than the BCLK rate - lots of clocks get specified as a multiple of the sample rate so it's not jumping out which clock. The best I can come up with is _bclk_fs() but perhaps there are better ideas? Or should we pass in a clock ID (and provide standard defines for things like BCLK) so it can apply to any clock?
Though looking at your ACPI ID patch perhaps pwgen can give us some good ideas :)