On Fri, May 5, 2017 at 12:24 PM, Andy Shevchenko andriy.shevchenko@linux.intel.com wrote:
On Fri, 2017-05-05 at 10:06 +0300, Amir Goldstein wrote:
[...]
I think with this semantic change, our proposals can reach common grounds and satisfy a wider group of users (i.e. filesystem developers).
Christoph also suggested a similar treatment to typedef guid_t to struct uuid_le. I don't know the use cases enough to comment on that.
We may go this way. But I wouldn't prevent current users of uuid_le to continue using it without conversion (it may be done case by case after we settle an API)
So, summarize what Christoph said it will look like
typedef uuid_be uuid_t; typedef uuid_le guid_t
uuid_cmp() / uuid_copy() / uuid_to_bin() / etc guid_cmp() / guid_copy() / guid_to_bin() / etc
Correct? Christoph?
That looks right to me.
To complete the picture for folks not cc'ed on my patches, xfs use case suggests there is also justification for the additional helpers:
uuid_is_null() / uuid_equal() guid_is_null() / guid_equal()
Cheers, Amir.