28 Jun
2023
28 Jun
'23
4:47 p.m.
On Wed, Jun 28, 2023 at 10:51:30PM +0200, Amadeusz Sławiński wrote:
Use PCI device IDs from pci_ids.h header and while at it change to using PCI_VDEVICE macro, to simplify declarations. This allows to change magic number PCI vendor IDs to macro ones for all vendors. For Intel devices use device IDs macros where defined.
...
((pci)->device == 0x490d) || \ ((pci)->device == 0x4f90) || \ ((pci)->device == 0x4f91) || \ ((pci)->device == 0x4f92)))
Why are not these be added in the header as well for the sake of consistency?
...
/* CPT */
- { PCI_DEVICE(0x8086, 0x1c20),
- { PCI_VDEVICE(INTEL, 0x1c20), .driver_data = AZX_DRIVER_PCH | AZX_DCAPS_INTEL_PCH_NOPM },
With the first patch seems all of these (x86) can be converted to use PCI_DEVICE_DATA().
--
With Best Regards,
Andy Shevchenko