On Fri, 04 May 2018 03:23:57 +0200, Ruslan Bilovol wrote:
This patchset adds BADD profiles support from the USB Audio Device Class 3.0 spec [1].
BADD profile support is defined as mandatory feature of UAC3-compliant device, it should be implemented as a separate USB configuration.
Notable issue with BADD configuration is that it misses class-specific descriptors (and it's mandatory as per spec), so host should guess them from BADD profile number and parameters of endpoints (type, number of endpoints and max packet size)
This patchset adds support of all known/existing BADD profiles from the UAC3 specification.
First 5 patches are refactoring and improvements, and last 2 patches actually implement UAC3 BADD profiles support.
OK, these 5 look like a nice cleanup, so I'll apply them right now.
It's an alternative implementation comparing to [2], and doesn't build usb descriptors on the host but instead initializes alsa-usb structures with known parameters, so we don't need to keep whole class-specific descriptors in the driver since we anyway need to have BADD-specific logic.
For this essential one, I'd like agreements from you guys before taking it.
Through my quick glance over the code, it looks good enough, but obviously I haven't tested it at all, so it's no right judge.
As I'm going to be off in the next week from tomorrow, I'll be less responsive, but don't mind and go ahead for discussions :)
thanks,
Takashi
I've picked one Jorge's UAC1 patch-improvement and updated it to v4.17 wich contais recently introduced header's sanity checks.
Remaining part is to add interrupt endpoint support so we will be able to detect jack insertion in the Headset Adapter profile.
This has been tested on ARM and x86-64 machines with custom UAC3 gadget which I'll post later to linux-usb
Comments and testing are welcome.
v2:
- split refactoring patch to more atomic and bisectable changes as suggested by Takashi
- renamed "Side Tone"->"Sidetone" as suggested by Andrew
- revorked main BADD patch to have table lookup for checking BADD channels validity and to reduce identation as suggested by Takashi
- also removed code duplication in BADD patch by reusing common part of build_feature_ctl() func
v1: http://mailman.alsa-project.org/pipermail/alsa-devel/2018-April/134412.html
[1] http://www.usb.org/developers/docs/devclass_docs/USB_Audio_v3.0.zip [2] https://www.spinics.net/lists/alsa-devel/msg71614.html
Jorge Sanjuan (1): ALSA: usb: Only get AudioControl header for UAC1 class.
Ruslan Bilovol (6): ALSA: usb: stream: move audioformat alloc/init into separate function ALSA: usb: stream: refactor uac1/2 audio interface parsing ALSA: usb: stream: refactor uac3 audio interface parsing ALSA: usb: mixer: make string parsing independent of mixer_build state include: usb: audio-v3: add BADD-specific values ALSA: usb: add UAC3 BADD profiles support
include/linux/usb/audio-v3.h | 26 ++ sound/usb/card.c | 53 ++-- sound/usb/clock.c | 9 +- sound/usb/mixer.c | 351 +++++++++++++++++++--- sound/usb/mixer_maps.c | 65 ++++ sound/usb/stream.c | 687 +++++++++++++++++++++++++------------------ sound/usb/usbaudio.h | 2 + 7 files changed, 849 insertions(+), 344 deletions(-)
-- 1.9.1