At Tue, 18 Jan 2011 15:12:16 +0100, Adrian Knoth wrote:
Hi!
As announced a few days ago, I've integrated the offspring hdspm driver by Florian Faber. The new code now also supports the 36in/36out RME RayDAT cards and RME AIOs.
Thanks for the patch!
I tried to follow the kernel's coding style as much as possible, however, there are still a few overlong lines left. For example, I didn't want to break "if read_reg(...) & 0x3f" at "& 0x3f", as it worsens readability. If it's required to comply, feel free to add the missing line breaks.
This is no big issue. Would be better if the line fits in 80 chars, but it's no must.
Right now, RayDATs and AIOs can only operate on a single period size of 1024 samples, because these cards always use a fixed 16k buffer per channel and only vary interrupt frequency. I'm going to try to fix this after I've learned more about the PCM interface. ;) Any suggestions welcome.
Basically one patch should contain the changes that are build-clean, i.e. you can build cleanly after patching. Thus changing a header and *.c in separate patches doesn't work well.
Also, please use the generic variable types as much as possible for ioctl structs. Avoid use of enum or such, especially ones that are typedef'ed. In general, avoid typedefs in the kernel code as much as possible. Defining each enum type is no-go.
Second, don't define arrays in the header file. They must be in the body, not included headers.
Also, remember checkpatch.pl is your friend.
thanks,
Takashi