Personally I would look for a more descriptive verb for the subject. "Update" suggests that you might be adding or removing IDs, but I think this patch is basically a mechanical conversion to use macros instead of hard-coded hex. Maybe "Convert to PCI_VDEVICE" or something?
On Wed, Jun 28, 2023 at 10:51:30PM +0200, Amadeusz Sławiński wrote:
Use PCI device IDs from pci_ids.h header and while at it change to using PCI_VDEVICE macro, to simplify declarations. This allows to change magic number PCI vendor IDs to macro ones for all vendors. For Intel devices use device IDs macros where defined.
-#define IS_BXT(pci) ((pci)->vendor == 0x8086 && (pci)->device == 0x5a98) +#define IS_APL(pci) ((pci)->vendor == PCI_VENDOR_ID_INTEL && \
(pci)->device == PCI_DEVICE_ID_INTEL_HDA_APL)
The actual content change seems fine, but the name change from BXT to APL seems like it might be material for a separate patch, possibly along with a similar name and comment change for bxt_reduce_dma_latency()?
static const char * const driver_short_names[] = { [AZX_DRIVER_ICH] = "HDA Intel", @@ -571,7 +572,7 @@ static void hda_intel_init_chip(struct azx *chip, bool full_reset) snd_hdac_set_codec_wakeup(bus, false);
/* reduce dma latency to avoid noise */
- if (IS_BXT(pci))
- if (IS_APL(pci)) bxt_reduce_dma_latency(chip);