On 25/02/2022 00:52, Bjorn Helgaas wrote:
On Thu, Feb 24, 2022 at 08:49:15AM +0100, Krzysztof Kozlowski wrote:
On 23/02/2022 22:51, Bjorn Helgaas wrote:
In subject, to match drivers/pci/ convention, do something like:
PCI: Use driver_set_override() instead of open-coding
On Wed, Feb 23, 2022 at 08:13:04PM +0100, Krzysztof Kozlowski wrote:
Use a helper for seting driver_override to reduce amount of duplicated code. @@ -567,31 +567,15 @@ static ssize_t driver_override_store(struct device *dev, const char *buf, size_t count) { struct pci_dev *pdev = to_pci_dev(dev);
- char *driver_override, *old, *cp;
int ret;
/* We need to keep extra room for a newline */ if (count >= (PAGE_SIZE - 1)) return -EINVAL;
This check makes no sense in the new function. Michael alluded to this as well.
I am not sure if I got your comment properly. You mean here:
- Move this check to driver_set_override()?
- Remove the check entirely?
I was mistaken about the purpose of the comment and the check. I thought it had to do with *this* function, and this function doesn't add a newline, and there's no obvious connection with PAGE_SIZE.
But looking closer, I think the "extra room for a newline" is really to make sure that *driver_override_show()* can add a newline and have it still fit within the PAGE_SIZE sysfs limit.
Most driver_override_*() functions have the same comment, so maybe this was obvious to everybody except me :) I do see that spi.c adds "when displaying value" at the end, which helps a lot.
Sorry for the wild goose chase.
I think I will move this check anyway to driver_set_override() helper, because there is no particular benefit to have duplicated all over. The helper will receive "count" argument so can perform all checks.
Best regards, Krzysztof