28 Mar
2023
28 Mar
'23
3:24 p.m.
+static int check_power_active(u32 __iomem *lctl, int sublink, bool enable)
Should last argument be named 'active' instead of 'enable'? It would make more sense to me.
Naming is the hardest part, eh?
I am not super happy with 'active', since the 'not-active' part is not very clear: it's not suspended, it's really powered-off/disabled.
I also didn't want to introduce a power state, since again it's on or off and we don't want to introduce the Dx concepts here.
If I had to revisit this, my preference would be:
static int check_sublink_power(u32 __iomem *lctl, int sublink, bool enabled)