[PATCH] ALSA: usx2y: Prefer struct_size over open coded arithmetic

Takashi Iwai tiwai at suse.de
Tue Sep 21 18:41:24 CEST 2021


On Sun, 19 Sep 2021 15:37:27 +0200,
Len Baker wrote:
> 
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
> 
> In this case this is not actually dynamic size: all the operands
> involved in the calculation are constant values. However it is better to
> refactor this anyway, just to keep the open-coded math idiom out of
> code.
> 
> So, use the struct_size() helper to do the arithmetic instead of the
> argument "size + size * count" in the kzalloc() function.
> 
> Also, take the opportunity to refactor the declaration variables to make
> it more easy to read.
> 
> [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
> 
> Signed-off-by: Len Baker <len.baker at gmx.com>

Thanks, applied.


Takashi


More information about the Alsa-devel mailing list