[alsa-devel] [PATCH 07/10] ASoC: soc-pcm: add snd_soc_dpcm_can_be() and remove duplicate code

Pierre-Louis Bossart pierre-louis.bossart at linux.intel.com
Thu Feb 13 16:56:45 CET 2020



> +int snd_soc_dpcm_can_be_free_stop(struct snd_soc_pcm_runtime *fe,
> +		struct snd_soc_pcm_runtime *be, int stream)
> +{
> +	enum snd_soc_dpcm_state state[] = {
> +		SND_SOC_DPCM_STATE_START,
> +		SND_SOC_DPCM_STATE_PAUSED,
> +		SND_SOC_DPCM_STATE_SUSPEND,
> +	};

should this be const?


> +	enum snd_soc_dpcm_state state[] = {
> +		SND_SOC_DPCM_STATE_START,
> +		SND_SOC_DPCM_STATE_PAUSED,
> +		SND_SOC_DPCM_STATE_SUSPEND,
> +		SND_SOC_DPCM_STATE_PREPARE,
> +	};

const as well?


More information about the Alsa-devel mailing list