[alsa-devel] [PATCH] ASoC: samsung: odroid: Use common code in odroid_audio_probe()

Krzysztof Kozlowski krzk at kernel.org
Thu Jul 18 11:58:47 CEST 2019


On Thu, 18 Jul 2019 at 11:57, Markus Elfring <Markus.Elfring at web.de> wrote:
>
> From: Markus Elfring <elfring at users.sourceforge.net>
> Date: Thu, 18 Jul 2019 11:42:29 +0200
>
> Replace a function call and a return statement by a goto statement so that
> a bit of common code will be reused at the end of this function.
>
> Signed-off-by: Markus Elfring <elfring at users.sourceforge.net>
> ---
>  sound/soc/samsung/odroid.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/sound/soc/samsung/odroid.c b/sound/soc/samsung/odroid.c
> index f0f5fa9c27d3..d152ef8dfea3 100644
> --- a/sound/soc/samsung/odroid.c
> +++ b/sound/soc/samsung/odroid.c
> @@ -316,8 +316,7 @@ static int odroid_audio_probe(struct platform_device *pdev)
>         }
>
>         of_node_put(cpu_dai);
> -       of_node_put(codec);
> -       return 0;
> +       goto err_put_node;

No, it does not look good. It makes the code and flow more difficult to follow.

Best regards,
Krzysztof


More information about the Alsa-devel mailing list