[alsa-devel] [PATCH 1/2] ASoC: core: add component_dev_list on Card

Lars-Peter Clausen lars at metafoo.de
Tue Oct 25 11:38:19 CEST 2016


On 10/25/2016 03:20 AM, Kuninori Morimoto wrote:
> 
> From: Kuninori Morimoto <kuninori.morimoto.gx at renesas.com>
> 
> Current Card has Codec list (= codec_dev_list), but Codec will be
> removed in the future. Because of this reason, this patch adds
> new Component list in Card.
> In the same time, current Card has AUX list (= aux_comp_list).
> This patch replaces it by Component list and new flag (= has_auxliary)
> too
> 
> Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx at renesas.com>

Looks mostly good, thanks.

> ---
>  include/sound/soc.h  |  7 ++++---
>  sound/soc/soc-core.c | 21 ++++++++++++++++-----
>  2 files changed, 20 insertions(+), 8 deletions(-)
> 
> diff --git a/include/sound/soc.h b/include/sound/soc.h
> index 1ed9371..69f2ebf 100644
> --- a/include/sound/soc.h
> +++ b/include/sound/soc.h
> @@ -807,9 +807,10 @@ struct snd_soc_component {
>  
>  	unsigned int ignore_pmdown_time:1; /* pmdown_time is ignored at stop */
>  	unsigned int registered_as_component:1;
> +	unsigned int has_auxiliary:1; /* for auxiliary component of the card */

I'd name it just auxiliary. "has" is not really the right word here.

>  
>  	struct list_head list;
> -	struct list_head list_aux; /* for auxiliary component of the card */
> +	struct list_head card_list;
>  
>  	struct snd_soc_dai_driver *dai_drv;
>  	int num_dai;




More information about the Alsa-devel mailing list