[alsa-devel] [PATCH] ALSA: riptide: Use DIV_ROUND_UP

Takashi Iwai tiwai at suse.de
Thu Jun 30 08:35:52 CEST 2016


On Wed, 29 Jun 2016 16:56:28 +0200,
Amitoj Kaur Chawla wrote:
> 
> The kernel.h macro DIV_ROUND_UP performs the computation
> (((n) + (d) - 1) /(d)) but is perhaps more readable.
> 
> The Coccinelle script used to make this change is as follows:
> @haskernel@
> @@
> 
> #include <linux/kernel.h>
> 
> @depends on haskernel@
> expression n,d;
> @@
> 
> (
> - (n + d - 1) / d
> + DIV_ROUND_UP(n,d)
> |
> - (n + (d - 1)) / d
> + DIV_ROUND_UP(n,d)
> )
> 
> Signed-off-by: Amitoj Kaur Chawla <amitoj1606 at gmail.com>

Applied, thanks.


Takashi


More information about the Alsa-devel mailing list