[alsa-devel] [PATCH] ASoC: add RT5639 CODEC driver

Oder Chiou oder_chiou at realtek.com
Wed Mar 26 03:57:20 CET 2014

> -----Original Message-----
> From: Mark Brown [mailto:broonie at kernel.org]
> Sent: Wednesday, March 26, 2014 12:58 AM
> To: Stephen Warren
> Cc: Oder Chiou; Bard Liao; alsa-devel at alsa-project.org; lgirdwood at gmail.com;
> Flove
> Subject: Re: [alsa-devel] [PATCH] ASoC: add RT5639 CODEC driver
> On Tue, Mar 25, 2014 at 09:33:42AM -0600, Stephen Warren wrote:
> > On 03/25/2014 07:30 AM, Mark Brown wrote:
> > > Looking at the level of code similiarity between this and the rt5640
> > > driver I can't help but think that these should be supported from a
> > > single driver - a few quick spot checks of the register map suggests
> > > that there's at least some overlap.  There will need to be some
> > > device specific handling but it looks like there's more shared than not shared.
> > > What are the issues that prevent the code being shared, there may be
> > > something I've missed?
> > FWIW, I was informed internally (although this certainly isn't
> > normative) that RT5639 is RT5640 plus a DSP, and otherwise compatible.
> > Related, I have a board that has a RT5639 and I'm running the RT5640
> > driver on it for at least a simple use-case, without issue.

The RT5639 is a simplified version of RT5640. There was only a pair of DACs and there was no MONO out.
The RT5639 and RT5640 didn't have the DSP function, and the RT5642 was the RT5640 plus a DSP.
In our side, the Tegra4 was broken, and it also was EOL in your company.
So, do you have the code base of Tegra5 which can use for verifying the upsteam driver?

More information about the Alsa-devel mailing list