[alsa-devel] [PATCH 01/10] ASoC: core: Add snd_soc_dai_set_tdm_slot_xlate().
broonie at kernel.org
Wed Mar 5 07:30:15 CET 2014
On Wed, Mar 05, 2014 at 03:55:50AM +0000, Li.Xiubo at freescale.com wrote:
> This adds the function of snd_soc_dai_set_tdm_slot_xlate, which is almost
> One new signature of snd_soc_dai_set_tdm_slot discarding the mask
> Parameters, which could be generated by itself.
Right, so that's not a bad thing but the _xlate() naming is confusing -
Lars' point was that if a function is called _xlate() it would usually
be an operation used as part of DT parsing, not something called from
non-DT code. The new interface is probably a good thing but needs a
different name (perhaps _simple or something?) or we need to rename the
old one out of the way (it's slightly less flexible so we probably don't
want to remove it totally).
> And I want to provide one standard method for the drivers who are parsing
> The TDM information from the DT node.
This is a good goal.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 836 bytes
Desc: Digital signature
More information about the Alsa-devel