[alsa-devel] [PATCH 01/10] ASoC: core: Add snd_soc_dai_set_tdm_slot_xlate().

Lars-Peter Clausen lars at metafoo.de
Sat Mar 1 14:19:44 CET 2014

On 02/26/2014 04:59 AM, Xiubo Li wrote:
> For most cases the rx_mask and tx_mask params have no use for
> snd_soc_dai_set_tdm_slot(), because they could be generated by
> {XXX_ .}of_xlate_tdm_slot_mask().
> This patch add snd_soc_dai_set_tdm_slot_xlate() which will replace
> the snd_soc_dai_set_tdm_slot() in some use cases to simplify the
> code. And for some CODECs or CPU DAI devices there needed much more
> work to support the .of_xlate_tdm_slot_mask feature.
> This patch can be applied to most use case of the current DAI drivers.


I'm not quite sure I fully understand what this patch is trying to solve. It 
adds a variant snd_soc_dai_set_tdm_slot() that instead of taking a rx and tx 
mask calculates the masks based on the number of slots? In that case I don't 
really see how the xlate in the name relates to that. xlate is something 
you'd typically expect in a devicetree context. Maybe one should be called 
snd_soc_dai_set_tdm_slot() and the other snd_soc_dai_set_tdm_slot_and_masks()?

But another question is do we really need this? I don't see the problem that 
is solved by this patchset.

- Lars

More information about the Alsa-devel mailing list