[alsa-devel] Fw: [Bug 1155202] [Intel DZ77SL-50K, Intel PantherPoint HDMI, Digital Out, HDMI] No sound at all

Niraj Kulkarni kulkarniniraj at rediffmail.com
Wed Jan 22 15:20:23 CET 2014

Let me try to explain my findings:

> How does this magic sequence come?

By dumping Win7 driver's init sequence and reproducing it through ALSA driver.

>why does it need to set UNSOL flag at first?

No such need, I've put it after regular init so that only affected chipsets are reset again. Putting this anywhere around init code works (tried it).

>Is the while loop guaranteed to quit for a reasonable time?

Being household user, I can only confirm on my chipset. Only a thorough testing may ensure sanity.

>Can't it be simply calling azx_reset() twice?

It is interesting hardware bug which kicks in only during first init after power-on. So if  Win7 driver in qemu inits the board, and I simply plugin "unchanged" hda_intel afterwards, it still detects codecs. But multiple normal resets do not have any effect. Being no hardware expert, I can only speculate that tight spin loop after reset has the crux. A normal delay call there does not detect codec.

>And, yet another question comes up: doesn't S4 need the similar workaround? If S4 works, what's the difference?

Haven't tried with sleep-wake or hibernate-restore sequence yet.


You received this bug notification because you are subscribed to the bug




  [Intel DZ77SL-50K, Intel PantherPoint HDMI, Digital Out, HDMI] No

  sound at all

Status in “alsa-driver” package in Ubuntu:


Bug description:

  I am using ubuntu 10.04

  I expected sound

  Got no sound at all

  I am very new to ubuntu so I have no idea how to find the version of

  the package I am using

  ProblemType: Bug

  DistroRelease: Ubuntu 12.04

  Package: alsa-base 1.0.25+dfsg-0ubuntu1.1

  ProcVersionSignature: Ubuntu 3.2.0-38.61-generic-pae 3.2.37

  Uname: Linux 3.2.0-38-generic-pae i686

  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.


   **** List of PLAYBACK Hardware Devices ****

   card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]

     Subdevices: 1/1

     Subdevice #0: subdevice #0

  ApportVersion: 2.0.1-0ubuntu17.1

  Architecture: i386

  ArecordDevices: **** List of CAPTURE Hardware Devices ****



   /dev/snd/controlC0:  jan        1750 F.... pulseaudio


   Card hw:0 'PCH'/'HDA Intel PCH at 0xf7c30000 irq 45'

     Mixer name   : 'Intel PantherPoint HDMI'

     Components   : 'HDA:80862806,80860101,00100000'

     Controls      : 7

     Simple ctrls  : 2

  CurrentDmesg: [   24.291482] eth0: no IPv6 routers present

  Date: Thu Mar 14 08:53:13 2013

  InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release i386 (20120817.3)

  MarkForUpload: True

  PackageArchitecture: all



   PATH=(custom, no user)



  SourcePackage: alsa-driver

  Symptom: audio

  Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH failed

  Symptom_Card: Built-in Audio - HDA Intel PCH


   1750  jan       F.... pulseaudio


  Symptom_Jack: Digital Out, HDMI

  Symptom_Type: No sound at all

  Title: [, Intel PantherPoint HDMI, Digital Out, HDMI] No sound at all

  UpgradeStatus: No upgrade log present (probably fresh install)

  dmi.bios.date: 03/19/2012

  dmi.bios.vendor: Intel Corporation

  dmi.bios.version: SLZ7710H.86A.0055.2012.0319.2140

  dmi.board.name: DZ77SL-50K

  dmi.board.vendor: Intel Corporation

  dmi.board.version: AAG55115-300

  dmi.chassis.type: 3

  dmi.modalias: dmi:bvnIntelCorporation:bvrSLZ7710H.86A.0055.2012.0319.2140:bd03/19/2012:svn:pn:pvr:rvnIntelCorporation:rnDZ77SL-50K:rvrAAG55115-300:cvn:ct3:cvr:

To manage notifications about this bug go to:


More information about the Alsa-devel mailing list