[alsa-devel] Tenor TE8802, USB : clics and crackles during music play

Daniel Mack daniel at zonque.org
Tue Jan 14 15:34:17 CET 2014

On Sun, Jan 12, 2014 at 04:43:06PM +0100, Eric F wrote:
> Been searching for days on Internet for this issue, without luck :(
> I own a Teac UD-H01 : when connected via USB => crackles and clicks

Which tool are you using in userspace to test this? Did you try aplay?

> optical => no problem

I'm confused. According to


there is no optical output. Are you saying things only work if you
connect an optical input?

Are you absolutely sure that you're not dealing with analog audio
distortion? IOW: did you try the very same setup with a different OS?

> I want to use it as USB because it's asynchronous, so only a few jitter

I don't follow. According to the device specs, USB is the only option to
connect this thing?

> I've tried many kernels (3.12.7, 3.12.6) and the LTS that I use normally
> (3.10.25, 3.10.26) : not solved
> I've tried on a fresh ArchLinux install : no way
> I've tried Xubuntu : not better (plus they use pulseaudio)
> I've tried on my desktop's Arch Linux
> I'd like to know if any of you have a patch or a fix for the Tead UD-H01
> DAC when used via USB

The device exposes itself as USB audio v2 interface, so it should work
out-of-the-box. What's interesting is that there are two clock sources,
but only one is connected in the topology (bCSourceID = 12), and there
is no clock selector. Crackles could be related to wrong clocking, but
that's just guessing.

Please check whether the device works under Windows or Mac OS X.


More information about the Alsa-devel mailing list