[alsa-devel] [RFC][PATCH v2 00/13] speakers: Add support for capture/playback of PCM/MIDI

Stefan Richter stefanr at s5r6.in-berlin.de
Sun Jan 12 13:35:08 CET 2014

On Jan 11 Takashi Sakamoto wrote:
> (Jan 11 2014 00:57), Takashi Iwai wrote:
>  > Yeah, module names aren't that important.  And you can put
>  > MODULE_ALIAS("snd-firewire-speakers"), if any.
> OK. I decide to rename the driver to 'snd-oxfw, and add the alias.

I agree that it should be renamed, and 'snd-oxfw' looks good to me.  The
module alias wouldn't even be strictly necessary for a driver like this
(probably not present in initrd images etc.), but it doesn't hurt to
include it.

The constants which patch 13/13 adds to include/uapi/sound/{asound,firewire}.h
should of course be named accordingly then.
Stefan Richter
-=====-====- ---= -==--

More information about the Alsa-devel mailing list