[alsa-devel] [PATCH RFC 00/20] snd_device_* cleanups

Takashi Iwai tiwai at suse.de
Fri Feb 14 12:59:44 CET 2014

At Wed, 12 Feb 2014 11:52:07 +0100,
Takashi Iwai wrote:
> This batch is aimed for cleanups of snd_device_*() usages.
> The major change is to introduce SNDRV_DEV_CARD type and use it for
> the card-level object instead of SNDRV_DEV_LOWLEVEL.  The rest are
> simplification of snd_device_*() calls and management.

I'll postpone (or disregard) this series except for a couple of
patches that change from SNDRV_DEV_LOWLEVEL to SNDRV_DEV_CODEC.  They
have been merged to for-next branch.

The card-level objects can be better handled in card's private_free in
the end, as it seems...


More information about the Alsa-devel mailing list