[alsa-devel] [PATCH v2] ASoC: rt5640: Add minimal support for RT5642

Mark Brown broonie at kernel.org
Sat Apr 26 02:22:34 CEST 2014

On Fri, Apr 25, 2014 at 04:08:18PM -0600, Stephen Warren wrote:
> On 04/16/2014 08:24 PM, bardliao at realtek.com wrote:

> > Signed-off-by: Jarkko Nikula <jarkko.nikula at linux.intel.com>

> Is this derived from Jarkko's patch? If so, shouldn't he be listed as
> the author, not you? If it wasn't, then presumably his S-o-b line
> shouldn't be in the patch description.

It was derived but edited; I did check with Jarkko that he was OK before

> I can see why this patch causes the driver to support the wrong chip.
> However, I can't imagine why that causes all the log spew at startup.
> Perhaps the driver is just broken on RT5639 at present (although I don't
> recall seeing any issues when booting on a board that actually had
> one...) Is part of the driver keying off this now incorrect ID register
> read, yet some other part of the driver registering widgets/routes based
> on which entry matched in struct i2c_device_id rt5640_i2c_id, hence
> they're falling out of sync due to this change? If so, that seems like
> another bug that needs fixing.

I'd be surprised if it weren't the latter.  Either way it needs fixing.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: Digital signature
URL: <http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20140426/52a45de1/attachment.sig>

More information about the Alsa-devel mailing list