[alsa-devel] Invalid PCM pointer with CMI8738 and pcm.c buffer underuns

Andoru andoru.blah at gmail.com
Sat Apr 12 19:56:12 CEST 2014

> You need root privilege to debug
> sudo echo 11 > /proc/asound/card0/pcm0p/xrun_debug

$ sudo echo 11 > /proc/asound/card0/pcm0p/xrun_debug

# echo 11 > /proc/asound/card0/pcm0p/xrun_debug

So I did have root priviledges when I executed that command, and it still
gives me a Permission denied error.

I tried the command under root and it accepted the command but didn't print
anything after issuing the command. So I guess it worked?

> Check the system log , you should find the hwptr change at 10ms interval if
> vlc use period time of 10ms

Again, what system log? Be a little bit more specific please.

> Try different period time/size to verify that the hardware really support
> any  arbitrary period time/size requested by the application ?

VLC doesn't have any options or terminal parameters to be able to change the
period as you mention.

More information about the Alsa-devel mailing list