[alsa-devel] Can't get capturing from RME Hammerfall MADI card to work: sound loops & silcence

bruce brucep at netspace.net.au
Fri Sep 27 09:07:07 CEST 2013

Hi Niels,

Similar issues here, but can add it all seems to work absolutely fine with
alsa 1.0.15, but fails with 1.0.18+.
Alsamixer must be used to setup the card and Madi.
96k sampling also works if you set the madi into double-speed mode (on the
older alsa).
Can't compile 1.0.15 with later kernels unfortunately; some hooks seem to
have changed !

Got no reply on rme Linux forum.
On 27 Sep 2013 16:09, "Niels Laukens" <niels.laukens at innovatie.vrt.be>

> Hi,
> I'm trying to capture audio from an RME Hammerfall MADI card (PCI ID
> 10ee:3fc6). The setup previously worked fine on Windows, so I'm currently
> assuming that the card and the input signal is OK.
> I wrote a very simple ALSA-application that simply opens the device, sets
> the access format to NONINTERLEAVED (which seems to be the only option the
> card likes), selects 32bit sampling (although the audio is 24bit, ALSA
> rejects this option), 48kHz sampling and 64 channels (also, the only
> option the card accepts). Next, it loops with snd_pcm_readn() to get 100ms
> worth of audio, and dumps channel 10 to file. (Full source in attachement)
> The result is strange for various reasons:
> * The second half of every buffer returned by snd_pcm_readn() is always
> zero's.
> * The call seems to return way to fast: I would expect to get 48000
> frames/second, but judging from the timing of the snd_pcm_readn() call,
> it's more like 1536000 frames/second (i.e. 32 fold faster).
> * When playing back the resulting file, I do recognize some music, but it
> sounds like it's the same part over and over again. Also, restarting the
> capture program minutes later, returns the same (at least as far as my
> ears & brain can recall) fragment of audio.
> What am I doing wrong here? (Samples of the PCM-file are available upon
> request)
> I've also tried a related test with `arecord`, with similar but different
> results:
> * The audio was also interspersed with silence
> * The capture duration did not match the requested '-d' option: the
> recording was a factor of 2 shorter than requested.
> * There was more audio in the recording: if I manually cut out the silent
> parts, the audio sounded reasonable.
> What am I missing here?
> Is this the right place to ask? Or should this go to the RME forum?
> Thanks in advance,
> Niels
> _______________________________________________
> Alsa-devel mailing list
> Alsa-devel at alsa-project.org
> http://mailman.alsa-project.org/mailman/listinfo/alsa-devel

More information about the Alsa-devel mailing list