[alsa-devel] [RFC/RFT PATCH] ALSA: hda - hdmi: Add ATI/AMD multi-channel audio support

LANGLOIS Olivier PIS -EXT olivier.pis.langlois at transport.alstom.com
Wed Sep 25 17:17:22 CEST 2013


> Great to hear that, thanks. So Revision Id 3+ works :)
> I forgot to ask for it explicitely, but I guess you checked that channels
> seemed to mapped correctly (at least for each speaker you actually have)?

Absolutely. I haven't been explicit about it but I would have mention it if something was wrong in that regard. I have 8 speakers.

I have used speaker-test to test stereo, 5.1 and 7.1 mapping and the mapping is perfect.

One small detail that I have noticed is that there seem to be a small delay as I add more and more channels. With 8 channels, there might be up to 1 sec between the time speaker-test prints a channel name and the sound from previous chan stops and I start to hear noise from the new one.

I have concluded that this may come from my receiver that seem to reinitialize itself during each channel switch but I'm not totally sure.
> Also, could you paste the whole /proc/asound/card0/codec#0, for the
> record?

I'll provide that info to you when I'm back home later. For now, from what I remember, as it is the first thing that I have checked after having reloaded the driver with the patch, there is nothing printed there that reflect the new multi channel capability of the codec. but maybe it is me that does not know what to look for.

Also, if you want me to test functionality only available with my hardware revision, just prepare me small test cases. I'll be happy to run them. No chance that I run on 'advanced' features on my own as my ALSA usage is very simple.


CONFIDENTIALITY : This e-mail and any attachments are confidential and may be privileged. If you are not a named recipient, please notify the sender immediately and do not disclose the contents to another person, use it for any purpose or store or copy the information in any medium.

More information about the Alsa-devel mailing list