[alsa-devel] [RFC/RFT v2 0/4] ALSA: hda - hdmi: ATI/AMD multi-channel and HBR support

Anssi Hannula anssi.hannula at iki.fi
Thu Oct 24 21:06:28 CEST 2013

Hmm, I thought I replied to this but I guess not...

09.10.2013 07:32, Olivier Langlois kirjoitti:
>> Then please test everything again. I.e.
>>   o speaker-test -D hdmi:CARD=Generic,DEV=0 -c8 -r192000 -F S32_LE
> this work fine
>>   o Is there any difference seen
>>     with these, in the beginning/end (i.e. fade-out/in):
>>     speaker-test -D hdmi:CARD=Generic,DEV=0,AES0=0x04 -c2 -r48000
>>     speaker-test -D hdmi:CARD=Generic,DEV=0,AES0=0x06 -c2 -r48000
> I have the same result as before the last fix. AES0=0x04 works
> AES0=0x06 doesn't. No error is emitted from speaker-test but no sound is
> coming out speakers.

OK, that is actually expected, didn't think the test through :)

>>   o Also, is there a difference in the beginning of these
>>     (maybe garbage sound and/or slightly slower startup?):
>>     aplay -Dhdmi:CARD=Generic,DEV=0,AES0=4 -r44100 -f s16_le -c2
>> testi.dts.cut.spdif
>>     aplay -Dhdmi:CARD=Generic,DEV=0,AES0=6 -r44100 -f s16_le -c2
>> testi.dts.cut.spdif
> no garbage. Maybe slightly slower startup with AES0=0x6.

OK, a bit unexpected but not totally strange.

>>   o Contents of /proc/asound/cardX/eld#0.0
>> Thanks a lot :)
> monitor_present		1
> eld_valid		1
> monitor_name		SC-09TX
> connection_type		HDMI

Looks OK, thanks for testing. Do you happen to have an EDID handy for
the receiver, just to double-check the data matches? Not sure how it is
available with fglrx driver, maybe in /var/log/Xorg.0.log...
No need to go to extraordinary lengths to get it, though :)

Anssi Hannula

More information about the Alsa-devel mailing list