[alsa-devel] [RFC/RFT v2 0/4] ALSA: hda - hdmi: ATI/AMD multi-channel and HBR support

Anssi Hannula anssi.hannula at iki.fi
Sun Oct 6 14:07:39 CEST 2013

06.10.2013 06:48, Olivier Langlois kirjoitti:
>>>>   o Contents of /proc/asound/cardX/eld#0. I'd like to see the contents
>>>>     both with radeon and with the proprietary fglrx driver in use
>>> With fglrx 13.10 Beta 2:
>>> lano1106 at whippet2 /proc/asound/card0 $ cat codec#0 
>> Note I said eld#0, not codec#0 :)
>> Though I guess the correct filename is actually eld#0.0.
>> [...]
> My mistake.
> Here is the good content:

Does not look right. And after looking at the code I saw quite a big bug
which caused all of the rev3+ features to not work :)

Please change 0x1002791a to 0x1002aa01 in this part in the end of

#define is_amdhdmi_rev3(codec) \
	((codec)->vendor_id == 0x1002791a && ((codec)->revisi

Then please test everything again. I.e.
  o speaker-test -D hdmi:CARD=Generic,DEV=0 -c8 -r192000 -F S32_LE

  o Is there any difference seen
    with these, in the beginning/end (i.e. fade-out/in):
    speaker-test -D hdmi:CARD=Generic,DEV=0,AES0=0x04 -c2 -r48000
    speaker-test -D hdmi:CARD=Generic,DEV=0,AES0=0x06 -c2 -r48000

  o Also, is there a difference in the beginning of these
    (maybe garbage sound and/or slightly slower startup?):
    aplay -Dhdmi:CARD=Generic,DEV=0,AES0=4 -r44100 -f s16_le -c2
    aplay -Dhdmi:CARD=Generic,DEV=0,AES0=6 -r44100 -f s16_le -c2

  o Contents of /proc/asound/cardX/eld#0.0

Thanks a lot :)

Anssi Hannula

More information about the Alsa-devel mailing list