[alsa-devel] [PING!] Re: HDMI audio is not working on my new desktop

Alexander E. Patrakov patrakov at gmail.com
Sat Oct 5 14:19:06 CEST 2013

2013/10/5 Alexander E. Patrakov <patrakov at gmail.com>:
> 2013/9/5 Alexander E. Patrakov <patrakov at gmail.com>:
>> 2013/8/22 Alexander E. Patrakov <patrakov at gmail.com>:
>>> 2013/8/22 Wang Xingchao <wangxingchao2011 at gmail.com>:
>>>> cc Mengdong and Liam, we're in the same PRC audio Team.
>>>> 2013/8/21 Alexander E. Patrakov <patrakov at gmail.com>:
>>>>> 2013/8/21 Wang Xingchao <wangxingchao2011 at gmail.com>:
>>>>>> Hi Takashi/Alexander E. Patrakov,
>>>>>> 2013/8/20 Takashi Iwai <tiwai at suse.de>:
>>>>>>> Xingchao, could you take a look at this bug?
>>>>>> sure, i will take a look at it.
>>>>>> But i'm afraid i cannot continue tracking from next week, i'm under
>>>>>> leaving process at Intel.
>>>>> Best wishes to you, and good luck with a new job :)
>>>>> But then please tell us the contact information of the person at Intel
>>>>> who should be contacted instead of you for any further questions
>>>>> related to HDMI audio on Haswell.
>>>>>> At first glance, i saw a lot of errors:
>>>>>> [  772.822663] playback write error (DMA or IRQ trouble?)
>>>>>> [  782.912776] playback write error (DMA or IRQ trouble?)
>>>>>> [  793.002904] playback write error (DMA or IRQ trouble?)
>>>>>> [  803.093052] playback write error (DMA or IRQ trouble?)
>>>>>> [  813.183205] playback write error (DMA or IRQ trouble?)
>>>>>> [  823.273217] playback write error (DMA or IRQ trouble?)
>>>>>> I know this issue on some Haswell ULT boards(STP/WTM1) because they
>>>>>> are not stable, and it's better to use latest BIOS image(V131 or
>>>>>> later).
>>>> btw, did you do any suspend/resume operation before the audio playback test?
>>>> if not, it's a new case. i found the issue only on some particular
>>>> boards after suspend/resume.
>>> The issue is 100% reproducible without suspend/resume. Just in case, I
>>> tested after one suspend-resume cycle, it didn't fix the problem.
>> On IRC (#intel-gfx) ohsix said that the bug
>> (https://bugzilla.kernel.org/show_bug.cgi?id=60769) may be graphics
>> related after all, but was too scared with the interrupt handling code
>> there. The contents of /proc/interrupts are attached to the bug, but
>> he said there is nothing interesting there.
>> BTW I am surprised that the bug is still assigned to Jaroslav Kysela
>> and not to Intel specialists (who are not even in the CC list of the
>> bug).
>> --
>> Alexander E. Patrakov
> broonie at kernel.org asked to CC: him to the thread. As far as I know,
> Intel tried to reproduce this bug on their hardware and on some OEM
> boards, but didn't try exactly the same motherboard, and reproduced
> another bug (files play silently but IRQs seem to come correctly).
> It is interesting to know that today I found two people on FreeNode
> IRC with the same board, and only one of them (rvalles) can reproduce
> the IRQ problem. The other one (broonie) uses an older kernel
> (Debian's 3.10-3, current unstable) and sees the "files play silently"
> problem instead of the IRQ one.
> --
> Alexander E. Patrakov

I have tried the Debian kernel on my Gentoo system and... HDMI audio
works (but always plays both in the Dell monitor and the LG TV
simultaneously). So this is a regression, will bisect.

Alexander E. Patrakov

More information about the Alsa-devel mailing list