[alsa-devel] Unsupported Valley View 'LPE' adapter?

Adam Williamson awilliam at redhat.com
Sat Nov 30 20:33:59 CET 2013

Hi, folks. I recently bought a Dell Venue 8 Pro -
a Bay Trail / Valley View-based Intel tablet - to try and get Fedora
running on it. Among the many things I'm currently fighting :) , the
sound doesn't work. snd-hda-intel is not loaded at all, and there are no
audio devices present at any level.

In Windows' Device Manager I see an 'Intel SST Audio Device' with PCI ID
0x86:0f28 . Indeed, the PCI ID database has this listed as "ValleyView
LPE Audio Controller" - http://pci-ids.ucw.cz/read/PC/8086/0f28 . But
hda-intel does not have 0f28 as a supported device. The commit for 'Bay
Trail' audio support added the ID 0f04:


So...what is this 0f28? Is support for it going to be added? Is there
any info I can provide to help? (I can boot Linux on the tablet and get
info out of it _just barely_, but it's pretty painful - there's no wifi
and an install to 'disk' (really a usb stick) doesn't work too well, so
I'm stuck working in a live image with no network).
Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | XMPP: adamw AT happyassassin . net

More information about the Alsa-devel mailing list