[alsa-devel] alsa-lib- not compatible with ppc64le architecture

Madhu Pavan kmp at linux.vnet.ibm.com
Thu Nov 28 06:47:26 CET 2013


We are in the process of adding support for new arch (ppc64le) and as 
part of that we wanted to send patches for config.guess and configure as 

alsa-lib- could not be built on ppc64le because it had an 
outdated configure/config.guess/libtool.m4. Since your pkg uses libtool 
and the latest tarball of your pkg didn't build on ppc64le due to 
outdated libtool present on your system. We wanted to request you to 
upgrade your libtool to the alpha release of libtool which has all the 
bits and pieces needed for ppc64le support.

In that context, I wanted to confirm the below

1) Should we send patches to this mailing list or there is some other 
mailing list ?

2) New libtool alpha release which supports ppc64le arch is available, 
you may  pick up the alpha release from either of the below :

ftp://alpha.gnu.org/gnu/libtool/libtool- (1.6MB)

ftp://alpha.gnu.org/gnu/libtool/libtool- (920KB)

It would be great if you can install this new libtool which supports 
ppc64le, and spin the pkg and let us know the new tar availability. We 
can test it on ppc64le architecture for you.
Please let me know if you are planning to release or spin newer version.

Currently I used


Which does not have ppc64le support.

Your response is highly appreciated.

Thanks in advance,
Madhu Pavan Kothapally

More information about the Alsa-devel mailing list