[alsa-devel] [PATCH 1/4] ALSA: hda - hdmi: Add ATI/AMD multi-channel audio support

Rafał Miłecki zajec5 at gmail.com
Fri Nov 1 00:25:44 CET 2013

2013/10/31 Anssi Hannula <anssi.hannula at iki.fi>:
>> But I can hear sound for rear right and rear left only :(
>> Is there anything more I can provide to help resolve this? Do you have
>> any idea how we can resolve this?
> According to the below the receiver has separate PCM SADs for 2-channel
> and multichannel playback. However, due to a radeon driver bug (see
> "[PATCH] drm/radeon/audio: fix missing multichannel PCM SAD in some
> cases", you were CCd) the multichannel SAD is lost and not shown below.
> However, that is not (or at least should not be) the reason you are not
> getting audio.
> I suspect that the receiver does not support 192kHz multichannel audio
> (which would be indicated in the missing multichannel PCM SAD). Does it
> work with 48kHz or 96kHz?
> (TODO: refuse PCM playback in such cases)
> If it does not work with 48kHz or 96kHz either, then we have a bug to
> solve :)

First of all, you're right about 2 SADs for PCM.

The weird thing is that 192kHz support... According to the EDID (SADs)
it should be supported:
Format: 1 (PCM)        Channels:1    Freq:0x7F (32-192)    B2:0x07 (16-24b)
Format: 1 (PCM)        Channels:7    Freq:0x7F (32-192)    B2:0x07 (16-24b)
Format: 2 (AC3)        Channels:7    Freq:0x07 (32-48)    B2:0x50 (640?)
Format: 7 (DTS)        Channels:7    Freq:0x06 (44-48)    B2:0xC0 (1536?)
Format: 10 (EAC3)    Channels:7    Freq:0x06 (44-48)    B2:0x00
Format: 11 (DTS_HD)    Channels:7    Freq:0x7E (44-192)    B2:0x01
Format: 12 (MLP)    Channels:7    Freq:0x1E (44-96)    B2:0x00

So I performed more tests and:

1) speaker-test -D hdmi:CARD=Generic,DEV=0 -c6 -r192000 -F S16_LE
A nice noise for rear right and rear left, silent for the rest

2) speaker-test -D hdmi:CARD=Generic,DEV=0 -c6 -r176400 -F S16_LE
A nice noise for rear right and rear left, short "bump" sound for the rest

3) speaker-test -D hdmi:CARD=Generic,DEV=0 -c6 -r96000 -F S16_LE
A nice noise for all speakers (the same applies to 88200, 48000, 44100, 32000)

I don't get it. Onkyo reports support for 192kHz and it supports it,
but only for 2 rear speakers... does it make any sense do you?


More information about the Alsa-devel mailing list