[alsa-devel] Problem opening default device in haswell system using aplay

Stefano Panella stefano.panella at citrix.com
Wed May 22 17:48:58 CEST 2013

Hi everyone,

sorry if this email has been sent twice... ( I sent it once before subscribing)

I am working on some haswell systems running Ubuntu 12.04 and I have a problem if I run aplay -D sysdefault.

when I do:

cat /proc/asound/pcm

I get:

00-03: HDMI 0 : HDMI 0 : playback 1
00-07: HDMI 1 : HDMI 1 : playback 1
00-08: HDMI 2 : HDMI 2 : playback 1
01-00: ALC662 rev3 Analog : ALC662 rev3 Analog : playback 1 : capture 1
01-02: ALC662 rev3 Analog : ALC662 rev3 Analog : capture 1

If I do:

aplay -L | grep sysdefault

I get:


where PCH is card number 1 (id = 1)

on most of my systems (non haswell laptops) the default card is number 0

If I run

aplay -D sysdefault

I get:

ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
aplay: main:682: audio open error: No such file or directory

if I strace it I get:

open("/dev/snd/pcmC0D0p", O_RDWR|O_NONBLOCK|O_CLOEXEC) = -1 ENOENT (No
such file or directory)

If I run:

aplay -D hw:PCH,0

all works fine...

Any idea why hw:PCH,0 works and sysdefault does not?

I guess there could be a problem in the mapping of devices in hw systems?

Has anybody else observed a similar issue? Or has this been a problem in
the past already fixed upstream?
If so, where was it fixed (kernel, lib, tools, utils, etc.) ?

Thanks for all your help on this.

In case this is a real problem I am willing to help debugging it and
submit patches.


More information about the Alsa-devel mailing list