[alsa-devel] Only stereo output possible with ATI Tahiti XT HDMI Audio [Radeon HD 7970 Series] [1002:aaa0]

Olivier Langlois olivier at trillion01.com
Wed May 15 15:46:59 CEST 2013


Just a small update to my ALSA journey. After having read the HDA spec,
I now realize that beside the IEC958 control reg, there is not much
programmable from the HDA side and if the audio widget caps says stereo
that is pretty much it, valid ELD or not.

Something that I ommited to mention in my original request, it is that I
am using the catalyst closed source driver. Apparently the video driver
has something to do in order to have audio working as the open source
radeon card has a parameter 'radeon.audio=1'.

I have also read that the opens source driver do not support yet the
7970 (aka Radeon SI Southern Islands) but I am intrigued and now that I
have hit a dead-end on the HDA front, I'll explore the radeon driver
source code to see what it does related to audio in these cards.

In the meantime, I have tried to setup an alternative with my given

lano1106 at whippet2 ~ :( $ cat /etc/asound.conf
pcm.mypcm {
   type plug
   slave {
     pcm "hdmi:{AES0 0x6 AES1 0x82 AES2 0x0 AES3 0x2}"

pcm.a52encode {
    type a52
    slavepcm mypcm

pcm.!default pcm.a52encode

lano1106 at whippet2 ~ $ speaker-test -c6

speaker-test 1.0.27

Playback device is default
Stream parameters are 48000Hz, S16_LE, 6 channels
Using 16 octaves of pink noise
Access type not available for playback: Invalid argument
Setting of hwparams failed: Invalid argument

Apparently, SND_PCM_ACCESS_RW_INTERLEAVED is not supported with my

Could I have seen it with something in /proc/asound ?
Is there a way to fix this with some kind of alsa plug setup?

Greetings and thank you in advance for your help,

More information about the Alsa-devel mailing list