[alsa-devel] No sound with Sony VAIO VPCZ1 (ALC889)

Tormen my.nl.abos at gmail.com
Fri Jul 5 14:00:45 CEST 2013


Thanks for your answer! :))

On 05/07/13 07:29, Takashi Iwai wrote:
> At Fri, 05 Jul 2013 00:53:48 +0200,
> Tormen wrote:
>> Hi again,
>> I digged again into google and stumbled across this thread from a year ago:
>> http://mailman.alsa-project.org/pipermail/alsa-devel/2012-March/050504.html
>> I have the same Notebook than Adam.
>> The thread stopped there. I contacted Adam and he confirmed me something
>> I also had noticed (but forgotten):
>>       The sound output via the speakers broke (went silent) between 3.1
>> and 3.2.
>>       It was working though for sometime between 3.2 and 3.9.6 - I
>> confirmed it to be working in 3.7!
>>       And now it is broken again.
> So, the speaker worked on *your* machine with 3.7 kernel?

> Then I need alsa-info.sh output in the working state.
*WORKING* sound (speakers play sound and everything else (from what I've 
seen so far) seems as it should)
uname -a:
Linux seven 3.7-trunk-amd64 #1 SMP Debian 3.7.8-1~experimental.1 x86_64 

This was without pulseaudio, without /etc/asound.conf and without any 
kernel module parameters to snd and snd-intel-hda.
I had also tried 3.9.6 under this conditions, but same problem.

I guess you need more debug? Unfortunately alsa-compile complained that 
the linux-source-3.7 package vanished in the meantime from experimental.
But I guess I can figure that out if you need more debug output (as in 
the debian 3.7 kernel image I am using CONFIG_SND_DEBUG is not set).

> Didn't you read my previous reply...? 
Sorry, I had missed it.

> Give alsa-info.sh outputs (don't paste, use attachments). At best, 
> give the outputs from both working and non-working kernels. Without 
> these, I cannot debug further. thanks, Takashi 
*NON-working* sound (speakers don't play any sound, headphone out works 
uname -a:
Linux seven 3.9-0.bpo.1-amd64 #1 SMP Debian 3.9.6-1~bpo70+1 x86_64 GNU/Linux

This is the debian 3.9.6 kernel + alsa-compile to get "debug=2" for 
snd.ko module to work as by default the CONFIG_SND_DEBUG is not set in 
debian kernels.

Hope that helps, please let me know.


More information about the Alsa-devel mailing list