[alsa-devel] [PATCH next-20130124] Sound: pci: Fix unused variable warning in patch_sigmatel.c

Takashi Iwai tiwai at suse.de
Fri Jan 25 10:09:56 CET 2013


At Fri, 25 Jan 2013 00:38:06 +0200,
Stratos Karafotis wrote:
> 
> Fix the following build warnings
> 
> sound/pci/hda/patch_sigmatel.c: In function ‘stac92hd71bxx_fixup_hp’:
> sound/pci/hda/patch_sigmatel.c:2434:24: warning: unused variable ‘spec’ [-Wunused-variable]

Thanks for catching.  But such temporal cast like your patch makes the
code readability much worse.  The code readability (thus its
maintainability) is a more important factor.

I'm going to fix the definition of snd_printd() itself for fixing this
kind of warnings.  We can use inline functions instead of empty macros
to achieve the same but without triggering compiler warnings.


Takashi

> 
> Signed-off-by: Stratos Karafotis <stratosk at semaphore.gr>
> ---
>  sound/pci/hda/patch_sigmatel.c | 14 +++++---------
>  1 file changed, 5 insertions(+), 9 deletions(-)
> 
> diff --git a/sound/pci/hda/patch_sigmatel.c b/sound/pci/hda/patch_sigmatel.c
> index 0aa0ceb..f269d1f 100644
> --- a/sound/pci/hda/patch_sigmatel.c
> +++ b/sound/pci/hda/patch_sigmatel.c
> @@ -2365,7 +2365,6 @@ static void stac92hd71bxx_fixup_ref(struct hda_codec *codec,
>  static void stac92hd71bxx_fixup_hp_m4(struct hda_codec *codec,
>  				      const struct hda_fixup *fix, int action)
>  {
> -	struct sigmatel_spec *spec = codec->spec;
>  	struct hda_jack_tbl *jack;
>  
>  	if (action != HDA_FIXUP_ACT_PRE_PROBE)
> @@ -2381,7 +2380,7 @@ static void stac92hd71bxx_fixup_hp_m4(struct hda_codec *codec,
>  	if (jack)
>  		jack->private_data = 0x02;
>  
> -	spec->gpio_mask |= 0x02;
> +	((struct sigmatel_spec *)codec->spec)->gpio_mask |= 0x02;
>  
>  	/* enable internal microphone */
>  	snd_hda_codec_set_pincfg(codec, 0x0e, 0x01813040);
> @@ -2420,19 +2419,15 @@ static void stac92hd71bxx_fixup_hp_dv5(struct hda_codec *codec,
>  static void stac92hd71bxx_fixup_hp_hdx(struct hda_codec *codec,
>  				       const struct hda_fixup *fix, int action)
>  {
> -	struct sigmatel_spec *spec = codec->spec;
> -
>  	if (action != HDA_FIXUP_ACT_PRE_PROBE)
>  		return;
> -	spec->gpio_led = 0x08;
> +	((struct sigmatel_spec *)codec->spec)->gpio_led = 0x08;
>  }
>  
>  
>  static void stac92hd71bxx_fixup_hp(struct hda_codec *codec,
>  				   const struct hda_fixup *fix, int action)
>  {
> -	struct sigmatel_spec *spec = codec->spec;
> -
>  	if (action != HDA_FIXUP_ACT_PRE_PROBE)
>  		return;
>  
> @@ -2456,8 +2451,9 @@ static void stac92hd71bxx_fixup_hp(struct hda_codec *codec,
>  
>  	if (find_mute_led_cfg(codec, 1))
>  		snd_printd("mute LED gpio %d polarity %d\n",
> -				spec->gpio_led,
> -				spec->gpio_led_polarity);
> +			((struct sigmatel_spec *)codec->spec)->gpio_led,
> +			((struct sigmatel_spec *)codec->spec)->
> +							gpio_led_polarity);
>  
>  }
>  
> -- 
> 1.8.1
> 


More information about the Alsa-devel mailing list