[alsa-devel] davici-mcasp: "tx-num-evt" confusion with number of serializers
mike.looijmans at topic.nl
Thu Feb 28 10:32:15 CET 2013
On 02/28/2013 10:06 AM, Michal Bachraty wrote:
> Hi Mike,
> Many thanks!
> Now all about "tx-num-evt" or "rx-num-evt" make sense.
>> Maybe the misleading "rx_num_evt" should be renamed to "use_rx_fifo". I
>> understand that not all McASP interfaces have a FIFO
> Maybe, "rx_fifo_depth" could be also used.
That's a big improvement over "rx_num_evt". The first time I saw this
struct, I thought I had to set rx_num_evt to the number of receiving AXR
pins in use.
Maybe call it "rx_min_fifo_depth" because just "depth" might be
interpreted as the capaciity or maximum size of the fifo, while in fact
the parameter is a minimum amount of data to be put into the FIFO
buffer. Of maybe "rx_fifo_thd" to indicate it's a threshhold. And use
the same name for the "tx" part as well (tx_fifo_thd or tx_fifo_min_depth).
More information about the Alsa-devel