[alsa-devel] [PATCH 0/3] Make HDMI ELD usable with hotplug

Ville Syrjälä syrjala at sci.fi
Mon Feb 18 23:39:42 CET 2013

On Mon, Feb 18, 2013 at 02:50:49PM +0100, David Henningsson wrote:
> On 02/18/2013 02:35 PM, Takashi Iwai wrote:
> > At Mon, 18 Feb 2013 14:11:10 +0100,
> > David Henningsson wrote:
> >>
> >> I'm experimenting with using ELD information in PulseAudio and found
> >> that it didn't work very well with hotplugging.
> >> Neither the proc file nor the ELD kcontrol was cleared correctly after
> >> unplug, and there was no way (except polling) to find out when ELD
> >> has become available.
> >
> > Did you try Xingchao's patch for drm/i915?  It's queued in
> > drm-intel-next:
> >
> >      commit 7b9f35a6dd72f89452c58bbdbaf063027bf857ec
> >      Author: Wang Xingchao <xingchao.wang at intel.com>
> >      Date:   Tue Jan 22 23:25:25 2013 +0800
> >
> >      drm/i915: HDMI/DP - ELD info refresh support for Haswell
> Thanks for the hint. I'm currently developing not on a Haswell machine, 
> but an (I think) Arrandale that I bought a few years ago. So I guess 
> this patch does not have any effect on my hw?

While reviewing that patch I asked whether we need something like that
on other platforms. Unfortunately I didn't get a real answer. The logic
in the patch would seem to apply equally to all platforms, not just HSW.
We also seem to be doing silly things like flipping the ELD valid bit
in the register on and off a few times when we update the ELD. But I'm
not all that familiar with the topic so take my ramblings with a pinch
of salt.

But in any case, if you're seeing a problem with the behaviour of i915
you should definitely report it.

Ville Syrjälä
syrjala at sci.fi

More information about the Alsa-devel mailing list