[alsa-devel] Lenovo ThinkCentre A58 - surround 5.1 problem

Raymond Yau superquad.vortex2 at gmail.com
Sat Feb 2 02:02:13 CET 2013

> I already tried so many options in alsa-mixer - as far as they where
possible to set. As we say im Germany: "I'm out of my latin" ;-)
> Any Ideas how to go on?
>>  >
>>  > I'm running a Lenovo ThinkCentre A58 with a ALC662 rev. 1 chip on
>> board. The mainboard has 3 jacks at the back of the PC and 2 ones at
>> it's front (mic and headphones).
>>  >
>>  > The problem is, that the connectors are not automatically arranged to
>> playback 5.1 surround sound. I must manually set the "model" to
>> "asusmode4" to get 5.1 and then run a script as root, to set the
>> backside jacks to output and to Center/LFE and rear speaker. Also I have
>> to mute the internal speaker.
>>  >
>>  > I've tried to patch the module manually, but this went wrong somehow.
>> I don't know how to proceed.
>>  >
>>  > So maybe you can help me and I can help you to complete the ALSA code
>> for this special mainboard/PC - hopefully.
>>  >
>>  > So long, I would thank you for your feedback.
>>  >

For a desktop with/without internal speaker, three audio jacks at rear

Green lineout jack , blue and pink jacks should have higher priority to
allocate DAC (audio output node 0x02, 0x03 and 0x04) than the headphone and
the internal speaker to support surround 5.1

This mean that in function parse_output_paths() to prevent the assignment
of dac speaker

-      bool fill_hardwired = true, fill_mio_first = true;
+       bool fill_hardwired = false, fill_mio_first = true;

Or use the existence of internal Mic to determine the value of

More information about the Alsa-devel mailing list