[alsa-devel] Linux Kernel-3.5 crashed as dapm is not supported by codec

Mark Brown broonie at opensource.wolfsonmicro.com
Fri Sep 21 13:14:56 CEST 2012

On Fri, Sep 21, 2012 at 09:27:47AM +0530, Rajeev kumar wrote:
> On 9/20/2012 5:19 PM, Mark Brown wrote:

> >DAPM is mandatory now, though any device with an audio interface
> >connected should have some DAPM widgets added transparently so its not
> >always explicitly present in the CODEC driver.  It's just causing too
> >much pain to special case non-DAPM devices and theres really not any
> >cases where there's no need for widgets.

> Is DAPM operates on event? In my device event generation is not
> there.Please correct me if I am wrong.

I can't parse the above, sorry.  Please clarify your question.

> Are there some dummy interface for DAPM? What are those interfaces?

No, DAPM is just there.

More information about the Alsa-devel mailing list