[alsa-devel] Linux Kernel-3.5 crashed as dapm is not supported by codec

Mark Brown broonie at opensource.wolfsonmicro.com
Thu Sep 20 13:49:52 CEST 2012

On Thu, Sep 20, 2012 at 04:46:27PM +0530, Rajeev kumar wrote:

> I have not provided the dapm support in codec. When the system goes
> in hibernation state it gets crashed. command for putting the system
> in hibernation:

DAPM is mandatory now, though any device with an audio interface
connected should have some DAPM widgets added transparently so its not
always explicitly present in the CODEC driver.  It's just causing too
much pain to special case non-DAPM devices and theres really not any
cases where there's no need for widgets.

More information about the Alsa-devel mailing list