[alsa-devel] a52: update to new libavcodec API

Takashi Iwai tiwai at suse.de
Tue Nov 13 07:29:41 CET 2012

At Sun, 11 Nov 2012 11:30:00 +0100,
Anton Khirnov wrote:
> Hi,
> this patchset updates the a52 plugin to work with the upcoming Libav 9
> release. In doing that, it drops support for pre-0.8 libavcodec
> versions. I think it is not unreasonable to demand at least a year old
> libavcodec to compile latest git of alsa-plugins and keeping
> compatibility with the old audio encoding API would result in ugly
> #ifdefery mess.

Thanks for the patches.

But, no, we still need the compatibility.  One year old is just a
baby; you can't guarantee that all users have already switched to it.

If #ifdef's are problems, you can write a cleaner code by splitting
files, too.


More information about the Alsa-devel mailing list