[alsa-devel] a52: update to new libavcodec API

Anton Khirnov anton at khirnov.net
Sun Nov 11 11:30:00 CET 2012

this patchset updates the a52 plugin to work with the upcoming Libav 9
release. In doing that, it drops support for pre-0.8 libavcodec
versions. I think it is not unreasonable to demand at least a year old
libavcodec to compile latest git of alsa-plugins and keeping
compatibility with the old audio encoding API would result in ugly
#ifdefery mess.

The plugin compiles and appears to work, but as I have no SPDIF
receiver, I cannot properly test it. I would very much appreciate it if
someone else could do that.

Please comment.

Anton Khirnov

More information about the Alsa-devel mailing list