[alsa-devel] snd-usb endpoint rework

Daniel Mack zonque at gmail.com
Tue May 22 00:53:42 CEST 2012

On 21.05.2012 20:45, Aurélien Leblond wrote:
>> Can you try using something like xmms maybe? I'm interested whether the
>> audio interface does consume any data or if the whole thing is stuck.
> This is now getting weirder and weirder, but here are the results of
> today's testing.
> Yesterday and today, I have been running the Kernel 3.2.16 with the Alsa git.
> Yesterday I couldn't play any sound whatsoever with the FTU, and the
> UA25-Ex was dying out after a few minutes.
> Today:
> (the testing is done using VLC connecting directly to ALSA, I removed
> pulseaudio from Ubuntu a few days ago to eliminate that as a possible
> cause)
> The first time I started my laptop with the FTU plugged - no sound,
> VLC is not hanging (I can see playing time move along).
> Unplugged the FTU, plugged back - VLC is now playing sound, but the
> sound quality is very "low-def" (I'm not sure how to explain that
> properly).

I think I ran into the same thing today. The reason for me was that the
new mixer controls that were added now allow setting the effect unit.
Actually, if you hear what I heared, this is just a simple reverb effect
that is overlayed. And yes, it sounds cheap :) I ran "alsamixer
-Dhw:Ultra" and switched all related controls off, and the the sound
came back again as expected.

> Restarting my laptop, FTU plugged in - VLC is now playins sound, still
> with very poor sound quality.
> Restarting my laptop with the UA-25Ex plugged in - VLC is working ok,
> sound quality is good, been running it for 10 minutes without a
> problem.

Might be the controls are not yet properly initialized, and the hardware
comes up in an undefined state. That would be easy to solve.

> Im both cases, starting Jack results in an immediate freeze of my
> laptop with CPU going 100% (I guess, as the laptop fan is going
> crazy), and I guess it is related as running Jack on the previous
> driver/original Ubuntu kernel is ok.

That is another issue then, but certainly something I need to look into.

> I cannot reproduce this problem anymore. If I encounter it again, I'll
> save a trace of the dmesg.
> It's quite hard to provide you with proper info as it almost looks
> like everyday produce a new scenario.

Usually the reason for loosing the overview is too many factors that are
involved when testing. Try to minimize the things you change from one
test run to the other as much as possible, and test extensively with one

> If there is anything I can provide to help, let me know,

Every bit and piece of empiric information is valuable and might help
finding the issue :)

Thanks for your help,

More information about the Alsa-devel mailing list