[alsa-devel] snd-usb endpoint rework

Daniel Mack zonque at gmail.com
Mon May 21 12:03:15 CEST 2012

Hi Aurélien,

On 20.05.2012 16:13, Aurélien Leblond wrote:
>> Hello everyone,
>> I compiled today the Kernel 3.4.0-rc7 from the git and used this git
>> to add the FTU support:
>> git://git.kernel.org/pub/scm/linux/kernel/git/tiwai/sound.git
>> Unfortunately, all my USB sound card simply stopped working.
>> The FTU doesn't produce any sound, nor through Alsa or Jack.
>> I tried playing a simple song through mplayer and nothing. I double
>> checked the mixer, all volumes are set as they should.
>> I checked dmesg, no error that could help.
>> I'm running Ubuntu, and the only thing I can hear is the welcoming
>> sound of ubuntu being cut-off almost instantly.
>> I tested my Edirol UA-25Ex, it is working all ok.
> Correction, the UA-25Ex doesn't work either.
> The sound dies out after a few minutes being used.

Odd. I did just that - built a kernel from Takashi's master branch - and
cannot reproduce the effect you're seeing. I'm testing with both the FTU
and a NI Traktor Audio 6 (which is a class compliant device) and both
stream reliable.

Are you totally sure that your hardware setup is ok? Did you change the
USB cables or anything? Does running an older kernel, while leaving
everthing else the same, solve the problem?

> When the sound dies out, dmesg prints:
> [  550.114621] urb status -32
> [  551.601237] urb status -32
> [  551.681206] urb status -32
> [  553.563336] urb status -32
> [  565.588044] urb status -32
> [  566.786965] urb status -32
> [  625.130221] cannot submit urb 0, error -28: not enough bandwidth
> If there is any other info I can provide, let me know,

Can you provide more context of the logs?


More information about the Alsa-devel mailing list