[alsa-devel] [PATCH 1/2] ASoC: core: Rename card mutex subclass to better align with usage.

Liam Girdwood lrg at ti.com
Fri Mar 9 13:02:07 CET 2012


Change SND_SOC_CARD_CLASS_PCM to SND_SOC_CARD_CLASS_RUNTIME to better
describe all uses for this mutex subclass and align with DAPM too.

Signed-off-by: Liam Girdwood <lrg at ti.com>
---
 include/sound/soc.h |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/include/sound/soc.h b/include/sound/soc.h
index 66fd9bc..0989987 100644
--- a/include/sound/soc.h
+++ b/include/sound/soc.h
@@ -289,8 +289,8 @@ enum snd_soc_pcm_subclass {
 };
 
 enum snd_soc_card_subclass {
-	SND_SOC_CARD_CLASS_INIT	= 0,
-	SND_SOC_CARD_CLASS_PCM	= 1,
+	SND_SOC_CARD_CLASS_INIT		= 0,
+	SND_SOC_CARD_CLASS_RUNTIME	= 1,
 };
 
 int snd_soc_codec_set_sysclk(struct snd_soc_codec *codec, int clk_id,
-- 
1.7.5.4



More information about the Alsa-devel mailing list