[alsa-devel] [PATCH v3] sound/soc/lapis: add platform driver for ML7213

Mark Brown broonie at opensource.wolfsonmicro.com
Thu Mar 8 12:05:49 CET 2012

On Thu, Mar 08, 2012 at 11:06:47AM +0900, Tomoya MORINAGA wrote:
> On Wed, Mar 7, 2012 at 8:46 PM, Mark Brown

> > You've still not explained the problem you're seeing but this sounds
> > like something that should work.  Please address the

> * Faced problem if there are no platform settings.
> machine driver's hw_params is not called
> platform_driver's functions(snd_pcm_ops, snd_soc_platform_driver) are
> not called.

> As a result, the following message is not showed . (by soc_pcm.c)
> printk(KERN_INFO "asoc: %s <-> %s mapping ok\n", codec_dai->name,
>          cpu_dai->name);

This makes no sense.  Registering a platform device will have *no*
impact on ASoC, it only cares if the relevant ASoC function drivers have
come up.  Probably there was some other problem with what you were doing
but it's hard to say...

> I can understand your concern.
> Let me clarify your think.
> You think that interrupt handler must check whether ALSA initialization has
> already finished or not before interrupt process executes.
> Right?

Or it should be safe to run even in the card has not come up yet, either
way is fine.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: Digital signature
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20120308/8475437d/attachment.sig 

More information about the Alsa-devel mailing list