[alsa-devel] ASOC - Codecs : Renaming of spdif_tranceiver.c
nitinmpai at gmail.com
Wed Mar 7 07:45:07 CET 2012
In my project I am feeling of need to have generic_codec. This will
provide the required codec_dais for the usecases like
-HDMI/SPDIF where there is no codec involved.
-For audio over MOST, where CPLD/glue logic is used
-For complex audio DSPs connected which will be mostly programmed in the
-SOC manufactures who would like to ship their drivers without having to
know what will be the final codec that will be present in the system.
Currently there is spdif_tranceiver.c which serves the purpose for spdif,
but using this for other usecases will create confusion while shipping the
What is the best way to carry forward?
1) Use spdif_tranceiver.c for all the purpose.
disadvantage: this will create more confusion while shipping.
2)Deprecate spdif_transciever.c and call it generic_codec. Change the dai
names and the function names.
3)Create another generic_codec.c and keep the spdif_transceiver.c and
deprecate the latter in next version.
4) Any other ideas ?
More information about the Alsa-devel