[alsa-devel] [PATCH v3 1/2] ALSA: ASoC: add DT bindings for cs4270

Hebbar, Gururaja gururaja.hebbar at ti.com
Tue Jul 31 05:54:39 CEST 2012

On Tue, Jul 31, 2012 at 02:12:31, Timur Tabi wrote:
> Daniel Mack wrote:
> > Signed-off-by: Daniel Mack <zonque at gmail.com>
> > Cc: Timur Tabi <timur at freescale.com>
> > ---
> Both patches:
> Acked-by: Timur Tabi <timur at freescale.com>
> I am seeing something a little weird, though, although I doubt it's
> related to these patches.  Audio works, even though I see this on the boot
> log:
> cs4270 0-004f: found device at i2c address 4F
> cs4270 0-004f: hardware revision 3
> Freescale MPC8610 HPCD ALSA SoC machine driver
> soc-audio soc-audio: ASoC machine snd-soc-mpc8610hpcd should use
> snd_soc_register_card()
> soc-audio soc-audio: Failed to register card
> platform soc-audio: Driver soc-audio requests probe deferral
> ...
> ALSA device list:
>   No soundcards found.
> soc-audio soc-audio: ASoC machine snd-soc-mpc8610hpcd should use
> snd_soc_register_card()

I believe you are registering "soc-audio" as a device.
In the "soc-audio" driver probe (souns/soc/soc-core.c - soc_probe()), 
this message is printed.

This is as per the commit below

commit fe4085e84f17a57a533a210a626e0cc9ead381f9
Author:     Mark Brown <broonie at opensource.wolfsonmicro.com>
AuthorDate: Fri Mar 2 13:07:41 2012 +0000
Commit:     Mark Brown <broonie at opensource.wolfsonmicro.com>
CommitDate: Fri Mar 2 16:21:25 2012 +0000

    ASoC: core: Log a warning when machines use soc-audio

    snd_soc_register_card() has been available and strongly preferred since
    2.6.38 but we're still seeing new drivers using it and the conversion rate
    for older machines has been low. Help address both issues by logging a
    warning when the soc-audio device probes.

    Signed-off-by: Mark Brown <broonie at opensource.wolfsonmicro.com>
    Acked-by: Liam Girdwood <lrg at ti.com>

> soc-audio soc-audio:  cs4270-hifi <-> e0016000.ssi mapping ok
> soc-audio soc-audio:  cs4270-hifi <-> e0016000.ssi mapping ok
> Is there a connection between the message "ASoC machine
> snd-soc-mpc8610hpcd should use snd_soc_register_card()", the requests for
> probe deferral, and the "No soundcards found." message?
> -- 
> Timur Tabi
> Linux kernel developer at Freescale
> _______________________________________________
> Alsa-devel mailing list
> Alsa-devel at alsa-project.org
> http://mailman.alsa-project.org/mailman/listinfo/alsa-devel


More information about the Alsa-devel mailing list