[alsa-devel] [PATCH] ia64: rename platform_* to ia64_platform_*

Luck, Tony tony.luck at intel.com
Wed Jul 25 20:37:22 CEST 2012

>> Is platform_name particularly special?

Yes. It is the symbol that is currently colliding with other subsystem namespace.

>> Perhaps it's be better to rename all the other
>> platform_<foo> uses to ia64_platform_<foo>
> That's good point in general, oh well I just wanted to make the minimal change..

Following that logic there isn't anything special about symbols starting with
"platform" ... and we should hunt down every global symbol in every architecture
that is local to the architecture and replace it with $arch_$symbol.

I think I'll just take the minimal patch to fix "platform_name" and continue to
use a "fix as problems occur" algorithm to the namespace pollution problem.


More information about the Alsa-devel mailing list