[alsa-devel] [PATCH] ASoC: tegra: use dmaengine based dma driver

Stephen Warren swarren at wwwdotorg.org
Mon Jul 2 18:46:59 CEST 2012

On 06/29/2012 05:34 AM, Laxman Dewangan wrote:
> Use the dmaengine based Tegra APB DMA driver for
> data transfer between SPI fifo and memory in
> place of legacy Tegra APB DMA.
> Because generic soc-dmaengine-pcm uses the DMAs API
> based on dmaengine, using the exported APIs provided
> by this generic driver.
> The new driver is selected if legacy driver is not
> selected and new dma driver is enabled through config
> file.
> Signed-off-by: Laxman Dewangan <ldewangan at nvidia.com>

Acked-by: Stephen Warren <swarren at wwwdotorg.org>
Tested-by: Stephen Warren <swarren at wwwdotorg.org>

(Tested on Cardhu/Tegra30. It fails on Whistler/Tegra20, but I assume
that's due to a bug in the dmaengine driver not this patch. There won't
be a regression when applying this patch since we haven't switched to
dmaengine as the default yet).

More information about the Alsa-devel mailing list