[alsa-devel] REGRESSION: Webcam mic for 145f:015b not longer working with 1.0.24 and above (OK with 1.0.23)

Daniel Mack zonque at gmail.com
Tue Aug 28 07:44:04 CEST 2012

On 28.08.2012 00:19, Kostas wrote:
> On 27/08/2012 06:54 μμ, Kostas wrote:
>> On 27/08/2012 02:44 μμ, Daniel Mack wrote:
>>> On 27.08.2012 12:33, Kostas wrote:
>>>> On 27/08/2012 12:26 μμ, Daniel Mack wrote:
>>>>> On 27.08.2012 11:00, Kostas wrote:
>>>>>> Hi All,
>>>>>> I have a 'Trust Webcam' (USB ID: 145f:015b) that comes with a 
>>>>>> microphone.
>>>>>> The microphone works with Alsa 1.0.23 but it does not work with the
>>>>>> latest Alsa 1.0.25 neither with Alsa 1.0.24.
>>>>>> Apparently this is a regression.
>>>>>> What shall I do to figure out the source of the problem?
>>>>>> Here are attached my alsa-infos, with Alsa 1.0.23 (working), 
>>>>>> 1.0.24 (NOT
>>>>>> working) and 1.0.25 (NOT working).
>>>>> Can you provide dmesg protocols for both a working and a non-working
>>>>> case please?
>>>> Below are attached the dmesg files.
>>> Thanks - the logs look both good, I guess the interesting messages are
>>> only generated once you try to start the stream. Can you try this?
>> How i do that?
>> I tried to make a test call in skype and also recording a video in 
>> cheese but no changes in dmesg.
>> Is there another way to start the stream?
> Also tried to record voice with sound recorder...with alsa 1.0.23 
> recording is fine..i hear my voice when playback the file but with alsa 
> 1.0.24 and above nothing is recorded.
> In both cases nothing is changed in dmesg output.
> What else could i do to help you out?

Comparing the two dmesg logs, I'm under the impression that in the
second case (the newer kernel), the hda driver kicks in and creates a
sound device before the usb audio driver does. Hence, the default card
changes and you're recording from your internal sound card rather than
the Webcam.

Could you please send the output of 'aplay -l' in both cases?


More information about the Alsa-devel mailing list